AEM6 with SP1 problem

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

AEM6 with SP1 problem

maciej.majchrzak
Administrator
Hi All,

this is just to let you know that we've found some issues with newest Slice 4.2 working on AEM6 with Service Pack 1 installed. Due to Sling bug (https://issues.apache.org/jira/browse/SLING-3944) which is present in the SP1, Slice 4.2 may not start properly, resulting in Peaberry bundle being not active. To fix this problem it is suggested to either:
1) upgrade org.apache.sling.scripting.java bundle to version 2.0.12 which fixes the issue with incorrect export of javax.inject package (http://mvnrepository.com/artifact/org.apache.sling/org.apache.sling.scripting.java/2.0.12); or
2) install SP2 which contains above bundle

Cheers
Maciej